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About this Manual
This manual is meant as a reference for the Nanosurf easyScan 2 Control 
Software. It applies to software version 1.3.

For instructions for the day-to-day operation of the easyScan 2 instru-
ments, refer to the easyScan 2 AFM/STM Operating Instructions.

For more information on the optional Scripting interface, refer to the 
online help file easyScan 2 Programmers Manual, that is installed together 
with the easyScan 2 software.

For more information on the optional Nanosurf Report software, refer to 
the on-line help, included with the Nanosurf Report software.



THE MAIN WINDOW
The user interface

This chapter explains the general concepts of the user interface that controls 
the functions of the easyScan 2 software. These functions are:

• Setting up the Nanosurf easyScan 2 hardware,

• moving toward the measurement position,

• performing measurements,

• displaying the measurement results,

• evaluating the measurements,

• permanently storing measurements and instrument.

These functions can be accessed via the easyScan 2 software, which is called 
‘workspace’. In the following, the workspace will be explained first, then 
the actual functions of the software will be discussed in more detail. The 
workspace of the easyScan 2 software consists of the following parts:

1. The main window,

2. operating windows,

3. measurement document windows,

4. tool bars,

5. control panels.

The main window

The main window is opened as soon as the easyScan 2 software starts. It 
gives access to the whole functionality of the easyScan 2 software, and con-
tains all other windows:

• The Main menu.

• Operating windows that are used to perform specific operations with the 
microscope.

• Measurement document windows that are used to evaluate previously 
made measurements.
7
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• Several tool bars that are used to issue commands. 

• Several control panels that are used to set measurement parameters.

• The Navigator that is used to quickly select between the most often used 
operating windows and panels.

• The Status bar that displays the state of the instrument.

Operating windows

Operating windows are used to perform specific operations with the micro-
scope. These operations are controlled using specific panels and tool bars 
that are part of these windows. The Operating windows are:

• Positioning window: positioning the tip with respect to the sample, with 
the aid of the built-in optical microscope (chapter Positioning (p.35)).

Navigator Main menu Tool bar

Operating windowPanel Status bar



MEASUREMENT DOCUMENT WINDOWS
• Imaging window: generating images of the sample (chapter Imaging
(p.39)).

• Spectroscopy window: measuring various ‘A as a function of B’ curves at 
certain sample locations, such as force-distance curves, or current-voltage 
curves (chapter Spectroscopy (p.46)).

Measurement document windows

The Measurement document windows visually represent previously made 
measurements. They are created when you decide to keep the current meas-
urement result. The measurement documents are used for storing, loading, 
printing and evaluating measurements. The measurement document is 
described in more detail in the chapters Viewing measurement data (p.51)
and Storing measurements and further data processing (p.65).

Tool bars

The tool bars can either be free floating windows (figure below, left), or 
they can be ‘docked’ to the top or the sides of the window they are associ-
ated with (Figure below, right).

    

Most tool bars dock to the Main window, some dock to a task specific 
window. 

Arranging tool bars
The tool bars have several features that allow you to arrange them in a way 
that is most efficient for your application.

To display a tool bar that is invisible, select the window it is associated with, 
and tick the tool bar’s name in the View menu. 

To dock a tool bar to the sides of its associated window, or to the side of, 
or below another tool bar that is already docked to this window, drag its 
title bar using the mouse cursor.
9
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To move a docked tool bar, use the mouse cursor to drag its handle on the 
left side of the tool bar. When the mouse cursor is over the handle, the 
cursor changes to a four pointed arrow.

To un-dock a docked tool bar, doulbe click its handle, or drag the handle 
outside the area reserved for tool bars on the sides of its associated window.

Control panels

Just like the tool bars, control panels can be either be free floating windows, 
or they can be ‘docked’ to the sides of the window they are associated with. 
Most control panels dock to the Main window, some dock to a task specific 
window. The control panels give access to specific functions of the easyScan 
2. The control panels contain one or more function sections, that can be 
collapsed and opened by clicking on the section header.

The number of visible sections and the number of visible parameters 
depends on the user interface mode selected in the User Interface Configu-
ration dialog (section The User Interface Dialog (p.13)). To see in which 
user interface mode a certain parameter is available, look at the title of the 
manual section in which it is described.

A stack of panels

Section header

Title bar

Section

Label

Parameter



CONTROL PANELS
Arranging control panels
The control panels have several features that allow you to arrange them in 
a way that is most efficient for your application.

A control panel associated with the main window is opened and brought on 
top of the other windows by clicking on its icon in the navigator. Any con-
trol panel can be opened and brought on top of the other windows, by 
selecting the window it is associated with, and ticking the panel’s name in 
the View menu.

Control panels can be stacked to save display space. When panels are 
stacked, labels are displayed on the bottom of the control panel stack. To 
put a  control panel on top of the stack, click its label. To add a control 
panel to a stack, drag either its title bar or its label to either the title bar or 
labels of the stack. To remove a panel from a stack, drag its label away from 
the stack.

To dock a (stack of) panels to the side of its associated window, or to the 
side of, or below another panel that is already docked to this window, drag 
its title bar to the desired position using the mouse cursor.

It is possible to scroll the content of a control panel up and down, when it 
is too small to display all the parameters it contains. To do this, move the 
mouse cursor over an area where it changes to a four pointed arrow. Then, 
drag the content up and down with the mouse cursor.

Storing and retrieving the workspace
When panels are opened, they appear at predefined places in the main win-
dow. This arrangement of the ‘workspace’ is stored in the configuration file 
‘Default EZ2-AFM.gui’ or ‘Default EZ2-STM.gui’ by default. The loca-
tion of the configuration files on the hard-disk depends on the operating 
system you use. Functions for storing and retrieving the workspace are 
accessed via the menu ‘File>Workspace’.

‘Save’ saves the workspace to the currently selected workspace file.

‘Save as...’ saves the current arrangement of the panels under another name.

‘Load’ loads a previously saved workspace.
11
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Entering values in the control panels
To change a parameter in any panel, use on of the following methods:

• Activate the parameter by clicking it with the mouse pointer, or by select-
ing it with the Tab key.

• The value of an activated parameter can be increased and decreased using 
the up and down arrow keys on the keyboard. The new value is automat-
ically used after one second.

• The value of a numerical parameter can also be increased and decreased 
by clicking the arrow buttons  with the mouse pointer. The new value 
is automatically used after one second.

• The value of an active numerical parameter can also be entered using the 
keyboard.  
The entered value is used on pressing the ‘Enter’ or ‘Return’ key, or by 
activating another input.  
The entered value is discarded on pressing the ‘Esc’ key. 
Type the corresponding character to change the unit prefix: 

For example, if the basic unit is Volts, type ‘m’ to change to millivolts, 
type the space bar for volts, type ‘u’ for microvolts.

• The selection of a drop-down menu (e.g.: ) can be 
changed using the mouse or the up and down arrow keys on the key-
board.

Sometimes the program will change an entered parameter value to a slightly 
different value. This happens when the desired value is outside the range 
that the easyScan 2 Controller can handle, for example due to the resolu-

prefix keyboard key prefix keyboard key
femto f no prefix space bar
pico p kilo k
nano n mega shift - M
micro u giga shift - G
milli m tera shift - T

Unit prefixes with corresponding character
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tion limits or timing limits. The desired value is automatically changed to 
the nearest possible value.

Storing and retrieving measurement parameters
All measurement parameters are stored in a configuration file with the 
extension ‘.par’. When the easyScan 2 software is started, default values are 
loaded from a file that is selected in the Controller Configuration Dialog 
(section The Controller Configuration dialog (p.31)). Functions for storing 
and retrieving parameters are accessed via the menu ‘File>Parameters’.

‘Save’ saves the parameters to the currently selected parameter file. The 
name of this file is indicated in the status bar at the bottom of the main 
window.

‘Save as...’, saves the parameters under a new file name. 

‘Load’ loads a previously saved parameter file.

Important! 
When you have not loaded another file, ‘Save’, will overwrite the original 
default parameter file with you current settings.

The User Interface Dialog

The User Interface dialog is opened via the menu ‘Options>Config User 
Interface...’

Program Skin
Select the look of the easyScan 2 software you are most comfortable with. 
All screen-shots in this manual were made with the Windows XP skin.

User Interface Mode
Determines the number of parameters displayed in the various panels:

Easy level only those parameters that are absolutely necessary to 
do a measurement

Standard level the commonly useful parameters

Advanced level all available parameters
13
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Options
Save workspace on exit
When active, the workspace settings are saved to the system registry when 
the software is exited (section Storing and retrieving the workspace (p.11))

Animated menu
When active, the opening of the menu is nicely animated.



THE OPERATING MODE PANEL
Hardware setup

Some changes to the hardware setup must be made during the operation of 
the microscope. Other changes are generally only made when the hardware 
is changed. The Operating mode panel and the Z-Controller panel are used 
to change the hardware setup during the operation of the instrument. The 
rest of the hardware setup is distributed over several dialogs that are reached 
via the Options menu. These panels and dialogs are discussed in this chap-
ter.

The Operating mode panel

The operating mode panel allows you to select the operating mode that you 
wish to use, and to set up several operating mode related parameters. The 
operating mode determines which signals are measured, and which signal is 
used to control the Z-position.  To open the Operating mode panel, click 

 in the navigator.

The number of available modes depends on the Scan head and on the mod-
ules built into the easyScan 2 controller. The modules required to be able 
to use a certain operating mode are listed in table Operating modes and 
required modules. The modes can be divided into the static operating modes 
that control the Z-position using the Cantilever deflection, the dynamic 
operating modes that control the Z-position using the vibration amplitude, 
and the STM mode that controls the Z-position using the tunnelling cur-
rent.

Operating mode Required modules
STM STM scan head
Static force AFM Basic
Dynamic force AFM Basic, AFM Dynamic
Phase contrast AFM Basic, AFM Dynamic, AFM Mode Extension
Force Modulation AFM Basic, AFM Dynamic, AFM Mode Extension
Spreading Resistance AFM Basic, AFM Dynamic, AFM Mode Extension

Operating modes and required modules
15
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The signals measured with each of the operating modes are listed in table 
Operating modes and measured signals. Note that the names of the signals 
can be changed in the ‘Scan Head Calibration’ dialog.

STM mode
This mode is only available when an STM head is connected to the control-
ler. In this case, it is the only available mode setting.

Operating mode (Easy, Standard, Advanced)

Mounted cantilever (Easy, Standard, Advanced)
Not available, this input is only used for AFM modes.

Operating mode (Easy, Standard, Advanced)
STM mode by default.

Operating mode Signals measured 
Static force Topography, Cantilever deflection(, User Input 1, 

User Input 2)
Dynamic force Topography, Vibration amplitude(, User Input 1, 

User Input 2)
Phase contrast Topography, Vibration amplitude, Vibration 

phase(, User Input 1, User Input 2)
Force modulation Topography, Cantilever deflection, Vibration 

amplitude(, User Input 1, User Input 2)
Spreading Resistance Topography, Cantilever deflection, Tip current(, 

User Input 1, User Input 2)
STM Topography, Tip Current (User Input 1, User 

Input 2)

Operating modes and measured signals:  The User Inputs are only avaliable when they are 
enabled and the Signal Module: A is installed.



THE OPERATING MODE PANEL
User Input/Output (Standard, Advanced)
See the description under Static Force mode.

Static Force mode
In the static force mode, the Operating Mode and User Input sections are 
available.

Operating mode (Easy, Standard, Advanced)

Mounted cantilever (Easy, Standard, Advanced)
The mounted cantilever type. The mounted cantilever type is used to auto-
matically determine the search range in the dynamic operating modes, and 
to determine the correct calibration for the force set point in the static oper-
ating modes.

Operating mode (Easy, Standard, Advanced)
Changes the operating mode.

User Input/Output (Standard, Advanced)

Enable User Input1, 2
When active, the data from the User input (manual Operating Instructions, 
chapter The Signal Modules) is measured and stored. Enabling the user 
inputs significantly increases the measurement file size.
17
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User Output 1, 2
The output value of the user output.

Config...
Opens the User Signal Editor dialog.

The User Signal Editor
The User Signal Editor dialog is used for editing the calibration of the User 
input signal. The same calibration values can also be edited in the Scan 
Head Calibration dialog. Changing the values here will also change the cor-
responding values in the Scan head calibration file.

Signal
Name
The name of the user signal. This name is used throughout the program to 
refer to the user signal.

Unit
The base unit of the physical signal, without prefix (i.e. m, not nm or µm).

Calibration
The physical signal values that correspond to the maximum and minimum 
signal voltages should be entered here. Prefixes can be used here.



THE OPERATING MODE PANEL
Dynamic Force mode
In addition to the same Operating mode and the User Input section as in 
the static operating mode, two sections of parameters may be available, 
depending on the user interface mode.

The dynamic force mode parameters can either be set manually or deter-
mined using an automatic search procedure. The automatic search starts 
with the coarse measurement of a cantilever resonance curve (figure Deter-
mination of the vibration frequency). Throughout this measurement, the 
cantilever is excited with a fixed amplitude, whilst the excitation frequency 
is varied. The resonance curve contains a measurement of the resulting can-
tilever vibration as a function of the excitation frequency. When the search 
is successful, the resonance curve contains a single peak at the free resonance 
frequency of the cantilever. Afterward, a second, fine-tuning search is per-
formed in a 3 kHz frequency range around the resonance frequency 
detected in the coarse search.

The computer adjusts the value of Vibration frequency so that the canti-
lever vibration amplitude is reduced by the amount set in ‘Amplitude 
reduction’ in the Freq. Peak Search section.

Mode Properties (Easy, Standard, Advanced)
Free vibration amplitude (Easy, Standard, Advanced)
The desired reference amplitude of the cantilever vibration. The cantilever 
vibrates at this amplitude when it is far away from the sample. The excita-

Determination of the vibration frequency

frequency

vi
br

at
io

n 
am

pl
it

ud
e

free resonance
frequency

vibration
frequency

amplitude
reduction
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tion strength is adjusted so that this vibration amplitude is reached.

Vibration frequency (Standard, Advanced)
The frequency at which the cantilever vibrates during the measurement. 
This frequency can automatically be set as described at the start of this sec-
tion. When ‘Auto set’ is enabled, the Vibration frequency is automatically 
set each time an approach is started. Clicking  starts the automatic 
setting immediately. 

Display sweep chart (Standard, Advanced)
When active, the results of the vibration frequency search measurements 
are transferred to a measurement document, and displayed on the screen.

  

Cantilever resonance curve: left: coarse search; right: fine-tuning search



THE OPERATING MODE PANEL
Freq. peak search (Advanced)

The parameters for the automatic vibration frequency search are set here.

Start frequency (Advanced)
The start frequency for the coarse search

End frequency (Advanced)
The end frequency for the coarse search

Step frequency (Advanced)
The difference between two frequency points at which the cantilever vibra-
tion amplitude is measured during the coarse search. If the increment is 
large, the search takes less time. When however the increment is too large, 
there is a risk that the resonance frequency may not be found.

Auto set (Advanced)
When active, the range and frequency increment are automatically set to 
suitable values for currently selected cantilever type.

Amplitude reduction (Advanced)
Indirectly determines the ‘Vibration Frequency’ in the ‘Auto set’ mode: 
The computer adjusts the Vibration frequency so that the cantilever vibra-
tion amplitude is ‘Amplitude reduction’ percent smaller than the vibration 
amplitude at the resonance frequency. 

Use upper sideband (Advanced)
When active, the vibration frequency is set larger than the resonance fre-
quency. Otherwise, the vibration frequency is set smaller. 
21
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Phase Contrast mode
In addition to the parameters in the Dynamic Force operating mode, the 
Reference Phase is available in the Standard and Advanced user interface 
modes.

Reference Phase (Standard, Advanced)
The reference phase for the detected cantilever vibration. Changing the ref-
erence phase changes the offset of the phase signal. The phase reference can 
be automatically set so that the phase signal is zero. When ‘Auto set’ is 
enabled the phase reference is automatically set after finishing the approach. 
Clicking  starts the automatic setting immediately. 

Force Modulation mode
In addition to the parameters in the Static Force operating mode, two addi-
tional parameters are available.

Excitation amplitude
The amplitude of the sensor excitation during a force modulation mode 
measurement.

Excitation frequency
The frequency of the sensor excitation during a force modulation mode 
measurement. Clicking  starts a measurement of the cantilever reso-
nance curve, that helps you to select the excitation frequency. The settings 
for this measurement are the same as those for the Dynamic Force measure-
ment.

Spreading Resistance mode
The operating mode panel for the Spreading Resistance mode is the same 
as that for Static Force operating mode.

The Z-Controller Panel

The tip-sample interaction is normally kept constant using the Z-Control-
ler. The Z-Controller is a PI(D) controller as is shown in figure Z- Control-
ler. The settings of this controller are set in the Z-Controller panel. To open 

the Z-Controller panel, click  in the Navigator.



THE Z-CONTROLLER PANEL
Z-Controller (Easy, Standard, Advanced)

Set point (Easy, Standard, Advanced)
The working point for the controller. Depending on the operating mode, 
this is the tunneling current (STM mode), cantilever deflection (static force 
mode) or relative cantilever vibration amplitude (dynamic force mode). In 
the latter case, the set amplitude is relative to the operating amplitude, set 
in the Operating mode panel. For example, when a set point of 70% is 
used, the controller will move the tip closer to the sample until the vibration 
amplitude has decreased to 70% of the vibration amplitude far away from 
the sample.

Loop-Gain (Easy)
The speed of the controller. If the gain is too low, the controller will not 
follow the surface fast enough. Thus, the image will not be as sharp as it 
could be. If the gain is too high, the controller will overshoot and may start 
to oscillate. Thus, the image will contain many measurement artifacts.

Z- Controller

Set point

Topography

Error
Signal+

-

+
Control Signal 
(Tip Current,
Deflection, 
Amplitude, ...) 1..16x

Error
Range

P-Gain

D-Gain

I-Gain

 dt

d 
dt

+

+
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P-Gain (Standard, Advanced)
The strength of the controller reaction that is proportional to the error sig-
nal. Increasing the P-Gain decreases the error signal.

I-Gain (Standard, Advanced):
The strength of the controller reaction that is proportional to the integral 
of the error signal. Increasing the I-Gain decreases the error signal over 
time. It is the least sensitive to noise, and usually the dominant contributor 
to the topography measurement.

D-Gain (Advanced)
The strength of the controller reaction that is proportional to the derivative 
of the error signal. Increasing the D-Gain decreases fast changes in the error 
signal, but also amplifies high frequency noise. The D-Gain is only availa-
ble in the ‘Standard PID’ Z-feedback mode of the Z-Controller (see follow-
ing section).

Z-Controller Mode (Advanced)

Z-Feedback Mode

Free Running The Z-Controller is active.

Freeze Position The Z-Controller is not active, the scanner remains in 
its current Z-position.

Stop and Clear The Z-Controller is not active, the scanner is moved 
to the ‘Ref. Z Plane’, set in the Imaging Panel.

The Probe Status light will blink green as long as the controller is deacti-
vated.

Important:
If the Ref. Z Plane is much lower than the current position of the tip, or 
the scan range contains large height differences, turning off the controller 



THE Z-CONTROLLER PANEL
(and clearing it) will result in the tip crashing into the sample, damaging 
the tip!

Z-Feedback algorithm

Standard PID A standard PID controller is used for Z-Feedback.

Adaptive PI A standard PI controller is used for feedback. In addi-
tion, the bandwidth of the Topography measurement 
is adapted to the number of measured points per sec-
ond.

The adaptive PI controller reduces noise in the measurement. However, 
topography changes that happen faster than the time between two meas-
ured points are also lost. This makes it more difficult to detect vibrations 
due to instability of the feedback loop. These vibrations remain visible in 
the Current, Amplitude or Deflection signal. Therefore, always monitor 
these signals when optimising controller settings, especially when using the 
Adaptive PI setting.

Error Range (Advanced)
The range of the error signal used to control the Z-Position. The error sig-
nal is the difference between the signal used for topography feedback and 
the current set point. When the value of ‘Error Range’ is reduced, the res-
olution of the error signal is increased.

Tip Properties (Standard, Advanced)

Tip Voltage (Standard, Advanced)
The potential to be applied to the tip. The usable voltage range is between 
-10V and +10V. In the STM, the sample is automatically connected to the 
ground of the instrument. In the AFM, the sample has to be electrically 
connected to the instrument chassis ground for accurate measurements.
25
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Cantilever types configuration

The cantilever types that you can select from in the Operating Mode Panel 
are configured using two dialogs: The cantilever browser, and the cantilever 
editor dialog. The cantilever types configuration is stored in a file called 
‘cantilever.ini’, located in the local settings directory of the user logged on 
to the PC.

The cantilever browser dialog

The cantilever browser dialog is opened via the menu ‘Options>Config 
Cantilever Types...’. The cantilever browser allows the editing and creation 
of cantilever types. 

New
Opens the cantilever editor dialog for a new cantilever type. You can create 
new cantilever types that are not defined in the default configuration. The 
AFM head requires the following cantilever properties:

• The bottom of the sensor chip must have grooves that fit into the align-
ment chip.

• The cantilever should have a nominal length of 225 µm or more, and a 
width of 40 µm or more.

• The back of the cantilever must have a coating that reflects infrared light. 
Uncoated cantilevers transmit much of the infrared light of the deflection 
detection system.



SCAN HEAD CONFIGURATION
Edit...
Opens the cantilever editor dialog to modify the currently selected canti-
lever type.

Delete...
Deletes the currently selected cantilever type using the cantilever editor dia-
log.

The cantilever editor dialog

The following properties of a cantilever type are entered in this dialog:

Name of cantilever
The name of the cantilever type. This name appears in the cantilever 
browser and the Cantilever type drop-down in the Operating Mode Panel.

Spring constant
The (nominal) spring constant of this cantilever type. This value is used to 
calculate the correct force Set point in the operating modes that use the 
static force for Z-Control. (section Static Force mode (p.17))

Resonance frequency
The (nominal) resonance frequency of the cantilever type. This frequency 
is used for the calculation of the automatic resonance frequency search 
range (section Dynamic Force mode (p.19)).

Scan head configuration

The scan head configuration is used to store all calibration values specific 
to a certain scan head. The configuration of each scan head is stored in a 
file with the extension ‘.hed’. This file is copied from the software installa-
27
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tion CD on installation of the instrument. When you change the scan head, 
you should also load the correct configuration file.

The scan head selector dialog
The scan head selector dialog is opened via the menu ‘Options>Config 
Scan Head...’. 

Load...
Loads a different scan head configuration file.

Save as...
Saves the current scan head configuration under another name.

Edit...
Edit the currently loaded scan head configuration using the scan head cali-
bration dialog. Always save a backup of the Scan head configuration by 
clicking ‘Save As...’.

The scan head calibration dialog
In this window the calibration of all Inputs and Outputs can be configured 
individually along with some scan head properties.



SCAN HEAD CONFIGURATION
Warning! 
Changes to these settings should be performed with great care. False set-
tings can lead to false interpretation of the data and false operation of the 
controller.

The available Output and Input signals and their calibration are listed in 
the upper  part of the dialog.

Outputs/Inputs/Signal
In the field ‘Signal’, a ‘Name’ and a ‘Unit’ are assigned to each Input and 
Output. These names along with their units are used by the program wher-
ever the signals are displayed.

Note that the inputs ‘Channel0...n’ are automatically configured by the 
software, depending on the measurement mode. Changing the settings for 
these inputs has no effect. An exception to this rule is Channel1.

Calibration
The ‘Calibration’ values indicate the maximum input and output range of 
the respective parameters and are used to calibrate the respective inputs and 
outputs. ‘Maximum’ is set for the positive range of the value, e.g. for a scan 
range of 100 µm a ‘maximum’ of 50 µm (+50 µm, -50 µm) must be set. 
‘Offset’ is the difference in value relative to zero.

The lower half of the dialog contains settings that enable the controller’s 
setting to be adapted to different scan head types. The figure Signal flow
shows where the settings take effect.

X/Y-axis orthogonality error
If the orthogonality of the scanner is not absolutely perfect, it can be cor-
rected by entering the appropriate angle for ‘X-Axis rotation’ and ‘Y-Axis 
rotation’. The scan axis coordinate system is rotated clockwise.

SetPoint Sign Check
The sign (+/-) of the ‘SetPoint’ is adjusted to the sign (+/-) of ‘Tip Voltage’:

none ‘SetPoint’ and ‘Tip Voltage’ have independent signs 
(normal AFM setting).

Equal to Tip Voltage‘SetPoint’ adopts the sign of ‘Tip Voltage’ (normal 
29
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STM setting).

Complement to Tip Voltage‘SetPoint’ adopts the opposite polarity to the 
‘Tip Voltage’.

CtrlInput correction
The Tip Voltage can be subtracted from the input signal before it is digi-
tised:

none the voltage from the scan head’s preamplifier is not 
changed (normal AFM setting).

Add TipVoltage Tip Voltage is added to the output voltage of the scan 
head’s preamplifier.

Sub TipVoltage Tip Voltage is subtracted from the output voltage of 
the scan head’s preamplifier (normal STM setting).

CtrlInput pol.
Before the measured signal is passed to the Z-Controller it can be inverted. 
Whether this is necessary depends on the type of scan head.

positive the signal remains unchanged (normal setting).

negative the signal is inverted.

Signal flow

CtrlInputCorr

CtrlInputPol

Z-AxisPol

Set point Setpoint

Z-Axis

Channel1 (Topography)

Tip voltage Tip voltage

Channel 0Channel0

+
-
0

+

+

Digital Analog

Slope
generator

±1

±1

+

-

+

Tip Current,
Deflection,
Amplitude, ...

Z-
Contr.

1..16x

Error
Range



THE CONTROLLER CONFIGURATION DIALOG
Z-Axis polarity
The output of the controller can be inverted after the alignment of the scan 
plane and output to the Z-axis.

positive the signal remains unchanged (normal STM setting). 

negative the signal is inverted (normal AFM setting).

The Controller Configuration dialog

The Controller configuration dialog is opened via the menu 
‘Options>Config Controller...’. On a correctly configured system, it should 
not be necessary to change the settings in this dialog, except for the startup 
parameters and chart arrangement file  configuration.

Start configuration
The parameter and chart arrangement files that are loaded when the soft-
ware starts (section Storing and retrieving the chart arrangement (p.52)).
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USB Connection
The easyScan 2 controller uses a virtual serial port that is connected to the 
USB port. The number of this virtual serial port should be the same as the 
one shown in your the windows device manager dialog.

Video Signal
The configuration of the easyScan 2’s internal video capture device. The 
default configuration should normally not be changed. This feature is only 
available when the video camera is installed.

Microscope Firmware
Click the Update button to install firmware updates that you receive from 
Nanosurf support.

The Edit Access Codes Dialog

The Edit Access Codes Dialog is used to enter the access code for software 
modules. At the moment, the only software module is the scripting inter-
face. The dialog is accessed via the menu entry ‘Options>Config Access 
Codes...’



THE SCAN HEAD DIAGNOSIS DIALOG
The Scan head Diagnosis dialog

The Scan head Diagnosis dialog is opened via the menu ‘Options>Check 
Scan Head...’. In it, the controller reports the current status information of 
the sensor or the approach platform. If the Status light on the easyScan 2
controller is blinking red, more detailed information about the failure is 
displayed in the ‘Microscope Diagnosis’ dialog.

Simulate Microscope

Check or uncheck the menu item ‘Options>Simulate Microscope’ to enter 
and exit the simulation mode. Once the simulation mode is active, the first 
field in the status bar of the easyScan 2 software displays the text ‘Simula-
tion’, otherwise this field displays the text ‘Online’.

In the simulation, many functions of the microscope are performed on a 
mathematically generated surface. Thus, the software functionality and 
working methods of the microscope can be practised.
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The About dialog

The About dialog displays the serial number of the connected Controller 
and version numbers of the installed modules. It is opened via the menu 
entry ‘?>About...’ If the microscope simulation is active ‘SerialNr. 000-00-
000’ is displayed. The Nanosurf Web site and contact address for informa-
tion and software updates are also displayed here.



THE APPROACH PANEL
Positioning

The Positioning window contains all the software tools for positioning the 
tip with respect to the sample:

• The Approach panel

• The Video panel (with the Video Module)

• The Video display (with the Video Module)

Click  in the Navigator to open the Positioning window.

The Approach panel

The motor for the tip-sample approach is operated using the ‘Approach 
Panel’. 

Approach (Easy, Standard, Advanced)
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Status
Displays the current status of the approach stage.

Increases the tip-sample distance at maximum speed until the button is 
released.

Decreases the tip-sample distance at maximum speed until the button is 
released.

Increases the tip-sample distance with the settings given in the Apporach 
Options.

Starts the automatic approach. During the automatic approach, the tip-
sample distance is decreased until the Set point, set in the Z-Controller 
panel, is reached, or until the maximum approach time is reached.

Approach Options (Standard, Advanced)

Appr. speed (Standard, Advanced)
The speed of the motor during the automatic approach and withdraw. 

Important!
If the approach is too fast, the sensor or the sample surface can be damaged. 
However, the motor will not move when Appr. speed is too small.

Max. Withdraw (Standard, Advanced)
The maximum withdraw duration after clicking .

Max. Approach (Advanced)
The maximum approach duration after clicking .



THE VIDEO PANEL
Auto. start imaging (Standard, Advanced)
When selected, the system automatically starts imaging after a successful 
approach. Scanning is automatically stopped when the approach motor is 
moved.

Auto reload settings (Advanced)
When selected, the software reloads the default start-up parameter file each 
time an approach is started (section The Controller Configuration dialog
(p.31)).

The Video panel

The video panel controls the video display in the Positioning window.
Changing these settings only has effect when a Video camera is fitted on 
your system.

Video source

The video source section determines which video signal is currently dis-
played.

Switches the video display to the top view.

Switches the video to the side view.

Saves the currently displayed image to a JPEG file that is selected using a 
Save file as... dialog.
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Video Options

The Video Options section determines how the video signal is displayed. 
There are separate sets of options for the side and the top view.

Illumination
The intensity of the sample illumination on the scan head.

Brightness
The brightness of the video display

Contrast
The contrast of the video display



THE VIDEO PANEL
Imaging

Imaging measurements of the sample are controlled using the Imaging win-

dow. The Imaging window can be opened by clicking  in the navigator. 
The Imaging window contains the Imaging bar, with commands that con-
trol the imaging processes, and the Imaging panel, with parameters that 
determine how the imaging is done.

The Imaging window also contains a number of charts that display the data 
from the ongoing measurement. The imaging window can display as many 
charts as the size of the window can accommodate. By default, two charts 
are displayed, a Line graph, and a Color map of the sample’s Topography. 
For more information on adding and changing charts (chapter Viewing 
measurement data (p.51)).

The imaging window
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The imaging bar

/
 starts a measurement and then changes to . Clicking  

aborts the measurement immediately. 

After clicking  the measurement stops when the current measurement 
has finished.

/
Starts a single measurement or changes the scanning direction of the meas-
urement in progress. With  the image is scanned from the bottom to 
top, with  it is scanned from the top to the bottom. If a measurement 
has been started using  or  the measurement stops automatically 
after one full image.

Selects an area that is to be measured in more detail. The size and area of 
the area is displayed in the Tool Results panel.

   

One corner of the zoomed area is defined by the mouse cursor position 
where the left mouse button is clicked, the opposite corner by the position 
where the button is released. When the mouse is not moved between click-
ing and releasing, an area is defined that has a size of 33% of the current 
measurement, and centred on the clicked location. Once an area is defined, 



THE IMAGING BAR
it can be resized by dragging one of its corners, and moved to the desired 
position by dragging its centre point. 
A double click with the left mouse button in the chart, or clicking the 
Zoom button in the Tool Results panel, modifies the parameters Scan 
range, X-, Y-Offset in the Imaging window accordingly. When the zoom 
function is active it can be aborted by clicking  again.

Moves the position of the imaged area. An interesting corner can thus be 
moved to the centre of the measurement. The Tool Results panel numeri-
cally displays the change in position.
The change in the position is indicated by an arrow. The start of the arrow 
is defined by the mouse cursor position where the left mouse button is 
clicked, the end of the arrow by the position where the button is released. 
When the mouse is not moved between clicking and releasing, an arrow 
ending in the centre of the measurement is drawn. The direction of the 
arrow can be adjusted by dragging its end markers, it can be moved by 
dragging the centre marker.
The image is moved by double clicking, or clicking the Move button in the 
Tool Results panel. The move function can be aborted by clicking  
again.

    

Returns the parameters Scan range to the largest possible values, and ‘X-
Offset’ and ‘Y-Offset’ to zero.
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Transfers the current measurement data to the spectroscopy window. If a 
measurement is in progress, it is interrupted. It is advisable to use  to 
complete the current measurement before starting the spectroscopy meas-
urement.

Captures the measurement currently displayed in the ‘Imaging window’ in 
a measurement document.

If  is clicked when a scan is in progress, the measurement document 
will generated when the measurement in progress is finished. During the 
scan, the button remains pressed. The capture process is cancelled by click-
ing  a second time.

To capture an image without waiting for the scan to be completed, stop the 
scanning by clicking . The image can then be captured immediately 
by clicking .

The measurement documents are labelled automatically with increasing 
numbers (i.e. Image1, Image2,...). When leaving the program you will be 
asked if you want to save the unsaved measurement documents. 

The Imaging panel

The imaging settings use two coordinate systems: The Scanner coordinate 
system and the Measurement image coordinate system. To separate the two 
systems, the image axes are denoted by an asterisk (i.e. X*, Y*). The relation 
between the two coordinate systems is determined by various parameters in 
the imaging panel. The effect of these parameters is illustrated in figure 
Coordinate systems.

Imaging Area (Easy, Standard, Advanced)
Image size (Easy, Standard)
The image size in both the X* and Y* direction. The size is doubled or 
halved when using .
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Image width (Advanced)
The image size in X* direction. The width is doubled or halved when using 

.

Height (Advanced)
The image size in Y* direction. The height is doubled or halved when using 

. When the Check-box is active, the image Height is always identical to 
the Image width.

Points / Line (Easy, Standard, Advanced)
The number of measured data points per line. 

Lines (Advanced)
The number of measured data lines in an image. When the Check-box is 
active, the number of Lines is always equal to the number of Points / Line. 
In the easy and standard user interface mode, the number of Lines is always 
equal to the number of Points / Line. 

Coordinate systems

X
Y

Z, Z*

Scanner XY-plane

'X-Slope' angle

'Y-Slope' 
angle

'Rotation' 
 angle

Measurement plane

Image area
X*Y*
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Time / Line (Easy, Standard, Advanced)
The time needed to acquire a data line. The time needed for the entire 
image is approximately:

Image time = ‘Time / Line’ · ‘Lines / Frame’ · 2    .

Rotation (Easy, Standard, Advanced)
The angle between the X-direction of the scanner and the X* direction of 
the measurement (figure Coordinate systems).

Imaging Options (Standard, Advanced)

The reference plane for the image can be aligned to the surface of the sam-
ple using the slope parameters (figure Coordinate systems).

X-Slope (Standard, Advanced)
A positive value rotates the image plane around the Y-axis in the counter-
clockwise direction.

Y-Slope (Standard, Advanced)
A positive value rotates the image plane around the X-axis in the counter-
clockwise direction. 

The centre position of the measured area can be changed by typing its posi-
tion as well as by using the Move tool in the imaging bar. The zero position 
is the centre position of the scanner.

Image X-Pos, Y-Pos (Advanced)
The centre position of the measured area.

Overscan (Standard, Advanced)
The amount by which the scan range of each line is made larger than the 
measurement range, relative to the image width. Thus edge effects, caused 
by the reversal of the scanning motion, are not displayed in the measure-
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ment. Disadvantages of using Overscan are that the maximum scan range 
is reduced, the tip moves slightly faster over the sample with the same 
‘Time/Line’ setting, and the tip may hit large features outside the measured 
image. The value of ‘Overscan’ determines how much the scan range is 
increased relative to the Image width.

Ref. Z-Plane (Advanced)
The height of the reference plane. This height reference is used when the 
Z-Controller output is cleared, and when the Z-position is not modulated 
relative to the current surface position during spectroscopy measurements.

Imaging Modes (Advanced)

Scan mode
The Y* direction in which the data is acquired and displayed:

Continuous the acquisition direction is reversed after each scan: 
from bottom to top and vice versa

Cont.Up from bottom to top

Cont.Down from top to bottom

Measurement mode
The X* direction in which the data is acuqired and stored:

Forward during forward scan only (left to right in the image)

Backward during backward scan only (right to left in the image)

Forw.&Backw. during both forward and backward scan
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Spectroscopy

In a spectroscopic measurement, the input channels are measured as a func-
tion of a modulated parameter. This modulated parameter can be the Z-
distance to the sample, the tip voltage, or a User output channel (when the 
Signal Module: A is installed). Note that you must electrically connect the 
sample to the ground connector on the easyScan 2 AFM scan head to apply 
a tip-sample voltage difference. The measured parameter can be any avail-
able input channel. Examples of a spectroscopic measurements are force/
distance curves in the AFM static force mode, amplitude/voltage curves in 
the AFM dynamic mode, or current/voltage curves with the STM.

The accuracy of the spectroscopic measurements can be increased by aver-
aging the measurement results of several consecutive modulations. A spec-
troscopic measurement sequence consists of a number of spectroscopic 
measurements of the same type, measured along a user defined line in the 
XY-plane. A point measurement is made if the number of points is one. 
The measurement sequence is carried out as follows:

1. The tip is moved with active Z-control to the start of the line.

2. The controller is switched off.

Spectroscopy window
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3. A spectroscopic measurement is recorded.

4. The controller is turned on again.

5. The tip is moved to the next point on the line in the XY-plane.

Steps 2.-5. are repeated for each points on the line. 

Spectroscopic measurement sequences are controlled using the Spectros-
copy window. The Spectroscopy window can either be opened by clicking 

 in the navigator, or by clicking  in the Imaging bar. When the 
Spectroscopy window is activated from the Imaging bar, the currently 
measured image is transferred to the Spectroscopy window. 

The Spectroscopy window contains the Spectroscopy bar, with commands 
that control the spectroscopy processes, and the Spectroscopy panel, with 
parameters that determine how the spectroscopy measurement is done. 

The Spectroscopy window also contains a number of charts that display the 
data from a previous imaging measurement and the data from the ongoing 
spectroscopic measurement. The Spectroscopy window can display as 
many charts as the size of the window can accommodate. It is recom-
mended to display at least two charts, one a Color map of a previous Topo-
graphy measurement of the area where the spectroscopy measurement is 
performed, and one a Dual Line graph of the current spectroscopy meas-
urement. For more information on adding and changing charts (chapter 
Viewing measurement data (p.51)).

The Spectroscopy bar

Starts a spectroscopy measurement sequence.

/
Starts the selection of the XY measurement position(s) in a topography 
Color map chart using the mouse cursor.  These positions are automatically 
transferred to the appropriate entries in the Position section of the Spectros-
copy panel. When selecting a line, clicking the chart once creates a line 
from the clicked position to the centre of the image.
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Captures the measurement currently displayed in the Spectroscopy window 
in a measurement document, and displays it in a separate window.
If  is clicked during the measurement, a copy is generated when the 
measurement in progress is finished. During the measurement, the button 
remains pressed. The capture process is cancelled by clicking  a second 
time.

The measurement documents are labelled automatically with increasing 
numbers (i.e. Image1, Image2, ...). When leaving the program you will be 
asked if you want to save the unsaved measurement documents.

The Spectroscopy panel

Modulation (Easy, Standard, Advanced)

Modulated output (Easy, Standard, Advanced)
The modulated output.

Start value/End value (Easy, Standard, Advanced)
The range over which the Modulated output is changed. The ‘Spec For-
ward’ data is measured from the Start to the End value, the ‘Spec backward’ 
data is measured in the opposite direction. The ‘Spec forward’ data is always 
measured before the ‘Spec backward’ data.

Relative to current value (Standard, Advanced)
When active, the Start and the End values are added to the value the mod-
ulatedy output had before starting the modulation.
When the Tip Potential is modulated, the current value is the Tip voltage 
set in the Z-Controller panel. 



THE SPECTROSCOPY PANEL
When the Z-Axis is modulated, the current value is the sample surface 
height, as measured using the Z-Controller output. Otherwise, the meas-
urement z-position is given by the value of the Ref. Z-Plane in the Imaging 
Panel.

Modulation time (Easy, Standard, Advanced)
The time used to change the Modulated output from the Start to the End 
value.

Measurement (Easy, Standard, Advanced)

Data points (Easy, Standard, Advanced)
The number of data points in one spectroscopic measurement. The data 
points are equally distributed over the modulation range.

Averages (Easy, Standard, Advanced)
The number of times the modulation is repeated to obtain an averaged 
spectroscopic measurement.

Input range check (Standard, Advanced)
In order to prevent tip damage due to too high tip-sample interaction, the 
settings below ‘Input range check’ define a safe range of tip-sample interea-
cion. When the interaction signal (Deflection in static modes, Amplitude 
in dynamic modes, Current in STM mode) leaves this safe range, the meas-
urement is aborted. When a spectroscopy measurement has been aborted, 
a warning dialog is displayed. The number of aborts that occurred in a 
measurement is reported in Data Info panel as: ModAborted=<number of 
aborts>.

Max / Min input value (Standard, Advanced)
The Minimum/maximum value that the feedback signal is allowed to have.
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Abort action (Standard, Advanced)
What is to be done when  the measurement is aborted:

Abort modulation aborts the current modulation period, and continues 
with the next modulation until the number of modu-
lations in ‘Averages’ is reached.

Abort current measurementaborts the spectroscopy measurement for the 
current point and continues with the next point of the 
line, if a  spectroscopy is being performed. 

Abort measurement sequenceaborts the entire spectroscopy measurement 
sequence (cancels all ‘Averages’ and points).

Position (Easy, Standard, Advanced)

The Position parameters can be used to define a sequence of spectroscopy 
measurements on positions that are equally distributed over a line.

Sequence Points (Easy, Standard, Advanced)
The number of Spectroscopy Measurements to be made in the sequence.

X-Pos from/Y-Pos from (Easy, Standard, Advanced)
The XY-coordinates of the measured point in a -spectroscopy meas-
urement. Sets the XY-coordinates of the starting point of the line in a -
spectroscopy measurement sequence.

X-Pos to Y-Pos to (Easy, Standard, Advanced)
The XY-coordinates of the end-point of the line in a -spectroscopy 
measurement sequence.

The from and to coordinates are more convenently chosen using the  
or  tools in the Spectroscopy bar.



CHARTS
Viewing measurement data

Measurement data are displayed in charts. Charts are used in Measurement 
document windows, the Imaging window and the Spectroscopy window. 
The measurement settings are displayed in the Data Info panel.

Charts

A Chart is a graphical representation of the measured data, and additional 
elements that give information about the chart itself (figure Elements of a 
Chart).

These elements show the displayed Signal, Chart type, the type of Filtering 
applied to the data, and the Color scale used to display the data. The Color 
scale shows which measured signal level is mapped to which colour. The 
colour mapping can be changed using the Color Palette dialog, described 
further on in this section. The Data range indicator shows the range of 
possible measurement values that is occupied by the measured data.

The Chart bar is used to create new charts and to modify their properties. 
The chart configuration of the Imaging and Spectroscopy window can be 
saved to a file. The chart configuration of the measurement documents is 
saved together with the document.

Elements of a Chart

Signal

Line selection arrow

Data range indicator

Color scale

Data filter

Chart range
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Storing and retrieving the chart arrangement
The chart arrangement of the Imaging and Spectroscopy windows is stored 
in a configuration file with the extension ‘.chart’. When the easyScan 2 
software is started, a default arrangement is loaded from a file that is 
selected in the Controller Configuration dialog (section The Controller 
Configuration dialog (p.31)). Functions for storing and retrieving the chart 
arrangement are accessed via the menu ‘File>Chart Arrangement’.

‘Save’ saves the chart arrangement to the currently selected chart file. The 
name of this file is indicated in the status bar at the bottom of the main 
window.

‘Save as...’, saves the chart arrangement under a new file name. 

‘Load’ loads a previously saved chart file.

Important!
When you have not loaded another file, ‘Save’, will overwrite the original 
default chart arrangement file with the current settings. 

The Chart bar 

The properties of the charts are set using the Chart bar. The settings dis-
played in the Chart bar refer to the currently active chart. This chart is 
indicated by a grey line around the chart. A Chart is activated by clicking it 
with the mouse cursor.

The following buttons control the creation and modification of the charts.

 (Create new Chart)
Creates a copy of the currently active chart and adds it as the last chart in 
the active window. Charts are first ordered top to bottom, then left to right. 
The window may have to be resized to see all charts.

 (Delete Current Chart)
Removes the currently active chart.

 (Chart type)
The chart type:

Line graph data is displayed as a plot. Points outside the range of 
the scanner are displayed in red. The displayed line is 
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selected by dragging the Line selection arrow in a 
Color map or Shaded map chart (figure Elements of a 
Chart (p.51)). 

Color map data is encoded in a color scale

3D view data is shown as a 3-dimensional representation in a 
parallel perspective.

Shaded map creates an impression of the surface with lighting from 
the left. This is achieved by combining the topography 
with its derivative.

Dual line graph both the Forward and the Backward data (when avail-
able) are displayed as in the ‘Line graph’. The line of 
the data type selected in ‘Signal’ is black, the line of 
the reverse direction data is grey. 

 (Data filter)
The way data is processed before it is displayed, evaluated or exported:

Raw data the data is not processed.

Mean fit the mean value of each line of data points is calculated 
and then subtracted.

Data represented using different chart types
53



VIEWING MEASUREMENT DATA

54
Line fit the best fit line for each line of data points is calculated 
and then subtracted.

Derived data the difference between two successive data points 
(derivative) is calculated.

Parabola fit the best fit parabola for each line of data points is cal-
culated and then subtracted.

Polynomial fit the best fit fourth order polynomial for each line of 
data points is calculated and then subtracted.

 (Signal)
The input channel that is displayed. The available signals depend on the 
operating mode, the status of the User input (section The Operating mode 
panel (p.15)) and the measurement mode (section The Imaging panel
(p.42)).

 (Optimise Chart range)
Adjust the chart scale so that it optimally fits the measurement data.

  (Decrease Chart range)
Halves the chart scale, thereby increasing feature contrast / height.

 (Increase Chart range)
Doubles the chart scale, thereby decreasing feature contrast / height.

 (Chart properties dialog)
Opens the chart properties dialog.

The Chart properties dialog

Chart range
Span
The signal span that corresponds to the full chart scale. Increasing Span 
decreases the feature contrast. The current Span is also displayed next to the 
color bar / axis in the chart

Center
The signal that corresponds to the center of the chart scale.

Auto set / set
When active, the chart scale is automatically set to optimally fit the meas-
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urement data, as it is being acquired. Clicking  has the same effect as 
clicking the Optimise Chart range button.

Chart size
Size
The size of the chart in pixels.

Show Axis
When active, the labels in charts and the color-bar in ‘Color map’ window, 
are displayed.

The Color Palette dialog

The color palette dialog is reached via the menu item ‘Options>Config 
Color palette...’. The color palette is used to map the display range of the 
measured values to a color. Three different palette types are available: 

Black&White The color map is a linear grey scale
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Color The color selection uses the HSB-color model where 
the color (H) is set in ° value. The color is selected by 
entering a number or by clicking a color in the color 
bar.

Look Up Table A user definable palette (with max. 256 color entries) 
can be selected. This palette is stored in a ‘.lut’ file that 
contains an ASCII table with RGB color values. A dif-
ferent look up table can be selected by clicking the 
‘Browse...’ button.

The Data Info panel

The Data Info panel displays the parameters of the active measurement and 
the current tool results.

Data Info Panel: Display of measurement parameters
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Quick Evaluation Tools

The easyScan 2 software has several tools that allow quick evaluation of a 
measurement while it is being acquired. This helps find optimal measure-
ment settings. For more elaborate evaluations, the optional Nanosurf
Report software package can be used (section Creating a report (p.67)).

The quick evaluation tools are activated using the Tools bar or the Tools 
menu. The number of tools available depends on the type of the currently 
active chart. The evaluation results are displayed in the Tool Results panel.

Important!
All results are calculated after the ‘Data filter’ has been applied to the data. 
The results will generally vary when a different ‘Data filter’ option is used.

The Tool Results panel 

The Tool Results panel displays the results of the currently active tool. The 
panel should automatically become visible when a tool is selected. To make 

the panel visible, click  in the navigator. The contents of the tool results 
panel depend on the tool that is active. It will always contain a Cursor posi-
tion and a Tool status section, and may also contain a Tool result and a 
Tool chart section. Because the content of the Tool Results panel depends 
so strongly on the active tool, this panel is described in more detail with 
each of the tools.

The Tools bar

Properties of the measurements can be evaluated numerically using the 
tools. The tools are activated via the corresponding menu item or by click-
ing the respective button in the tool bar. Tools can be used in all charts, 
both during measurement and off-line. Before using a tool on a chart, acti-
vate the chart by clicking onto it. To stop using a tool, select another tool, 
or click its button a second time.

 Measure Length
Starts measuring the distance and signal difference between two points. 
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The measurement results are displayed in the Tool Results panel.

The two points are defined by drawing a double arrow. The first point is 
defined by the mouse cursor position where the left mouse button is 
clicked, the second point by the position where the button is released. 
When the mouse is not moved between clicking and releasing, an arrow 
parallel to the X*-axis is drawn.

The direction of the arrow can be adjusted by dragging its end markers; it 
can be moved by dragging the centre marker.

  

 Measure Distance
Starts measuring the distance between two parallel lines. The measurement 
result is displayed in the Tool Results panel. 
Distance is measured by drawing two lines in the chart. The first point of 
the first line is defined by the mouse cursor position where the left mouse 
button is clicked, the second point by the position where the button is 
released. When the mouse is not moved between clicking and releasing, a 
line parallel to the X*-axis is drawn. After releasing the mouse button, a 
second parallel line sticks to the mouse cursor, that is released by clicking 
its desired position. The direction of the parallel lines can be adjusted by 
dragging their end markers; they can be moved by dragging the centre 
marker.
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 Measure Angle
Starts measuring the angle between features in the measurement. The meas-
urement result is displayed in the Tool Results panel. In Line graph-type 
displays, this tool can only be used when the signal displays height data.

  

The angle is measured by drawing two meeting lines in the chart. The first 
point of the first line is defined by the mouse cursor position where the left 
mouse button is clicked, the second point by the position where the button 
is released. When the mouse is not moved between clicking and releasing, 
a line parallel to the X*-axis is drawn. After releasing the mouse button, the 
end of the second line sticks to the mouse pointer. The end is released by 
clicking its desired position. The angle can be changed by dragging the 
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line’s end point markers or the corner mark; it can be moved by dragging 
the line’s centre markers.

 Create Cross Section
Displays and can create a new measurement document containing a line 
cross-section of a Color map display. The line is displayed in the Tool 
Results panel. The line can be stored in a new measurement document.

  

The line is defined by drawing an arrow. The arrow points toward the for-
ward direction of the line. The start of the arrow is defined by the mouse 
cursor position where the left mouse button is clicked, the end of the arrow 
by the position where the button is released. When the mouse is not moved 
between clicking and releasing, an arrow ending in the centre of the meas-
urement is drawn. The direction of the arrow can be adjusted by dragging 
its end markers; it can be moved by dragging the centre marker.

A new measurement document containing the line section is created by 
double clicking the graph, or by clicking ‘Cut out line’ in the Tool Results 
panel.

 Cut Out Area
Creates a new measurement document containing a subsection of an exist-
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ing measurement. The size and area of the area is displayed in the Tool 
Results panel.

  

One corner of the area is defined by the mouse cursor position where the 
left mouse button is clicked, the opposite corner by the position where the 
button is released. When the mouse is not moved between clicking and 
releasing, an area is defined that has a size of 33% of the current measure-
ment, and is centred on the clicked location. Once an area is defined, it can 
be resized by dragging one of its corners, and moved to the desired position 
by dragging its centre point. It is possible to define a rectangular (i.e. non-
square) area by pressing the ‘Shift’ key whilst dragging a corner.

A new measurement document containing the area is created by double 
clicking the graph, or by clicking the ‘Cut out area’ button in the Tool 
Results panel.

 Calculate Line Roughness
Calculates certain roughness parameters along a line. Both the selected line 
and calculated values are displayed in the Tool Results panel.
The cross-section is selected in the same way as with the Cut out Line tool.
The calculated parameters are stored in the measurement document when 
the ‘Store’ button in the Tool Results panel is clicked.

 Calculate Area Roughness
Calculates certain roughness parameters of an area. The calculated values 
are displayed in the Tool Results panel.
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The parameters are calculated as follows:

The area is selected in the same way as with the Cut out Area tool.
The calculated parameters are stored in the measurement document when 
the ‘Store’ button in the Tool Results panel is clicked.
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THE TOOLS BAR
  

Tip:
The Area Roughness tool can be used to determine the mean height differ-
ence between two plateaus with more accuracy than with the ‘Measure Dis-
tance’ tool. To determine the mean height difference, select an area on each 
plateau, and calculate the difference between their Sm-values. 

 Correct scan line levels
Removes the effect of a wrong scan plane or drift when the ‘average’ and 
‘plane’ Data filter options do not give satisfactory results. This may occur 
when the scan lines in different parts of the measurement have a different 
average height. An example of such a measurement is shown in figure Cor-
rect scan line levels. 
To use the tool, draw a line through points that should have the same 
height in the same way as with the Measure Length tool.
After clicking the ‘Execute’ button in the Tool Results Panel, the average 
level of each scan line is adjusted so that all points along the drawn line have 
the same height. To get useful results, the Data filter option for the display 
in which you draw the line should generally be ‘Raw data’ or ‘Mean fit’.
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Correct scan line levels: left: uncorrected image with a line through points that should be at the 
same height; right: corrected image



STORING AND PRINTING MEASUREMENTS
Storing measurements and further data 
processing

Storing and Printing measurements

Storing and Printing of measurement documents can be performed using 
the File menu. The functions Open, Save and Print are also available via the 
File bar.

Menu item ‘File’ contains the items for opening , closing, saving , and 
printing  the measurement documents and for exiting the program. In 
the following only the special functions are mentioned. 

 Open
Opens a dialog for opening Nanosurf .nid or .ezd (easyScan 1) files. The 
same dialog is  opened using the menu ‘File>Open...’. It is possible to select 
more than one file at the same time by using the ‘Shift’ and ‘Ctrl’ keys.

 ‘Save’ and ‘Save as...’
Save a measurement document in Nanosurf image data format (file exten-
sion .nid). The same dialog is  opened using the menu ‘File>Save’ and 
‘File>Save as...’. 

Export >Current Chart as / Current document as
Exports either the active chart or the whole active measurement document 
for use in other programs or image processing software. Available data types 
for documents are windows bitmap (.bmp), 16 bit data file (.dat), plot file 
(.plt). For Charts, additional available data types are comma separated z 
values (.csv), and (X,Y,Z)-points (.csv).

When the data is exported using the function ‘Export>Current document 
as..’, every Chart in the measurement document is stored in the export file 
consecutively. In the binary format, the blocks of data from each Chart are 
stored directly one behind the other. In the ‘ASCII’ text format the blocks 
of data for each Chart are separated by two empty lines.
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Windows Bitmap (.bmp)

A Windows Bitmap image is suitable for including in documents, e.g. word 
or image processing software. The exact image as seen on the computer 
screen will be saved in the file (‘screen shot’).

Data file 16Bit (.dat) 

A binary data file can be processed in image processing software. This 
‘binary’ data format contains only the measured data. The data is stored 
consecutively line by line upwards as 16-bit values (-32768 - +32767). The 
data is first processed using the settings chosen in the Data filter setting of 
the Chart bar.

Plotfile ASCII (.plt)

This is an ‘ASCII’ text format which contains the measured data as well as 
a small header with a description of the scan. The data is stored using the 
setting ‘Data filter’ in the ‘Chart bar’. A measurement as a plotfile can be 
used for detailed data analysis by various mathematical software packages 
such as  MathLab or plotted by GnuPlot.

• If ‘Line graph’ is selected as ‘Display’ in the ‘Chart bar’, only the visual-
ised lines will be stored. Each data point is stored as a pair of floating 
point numbers on a separate line. The number pairs are separated by a 
blank character (SPACE). 

• If any other chart type is selected, all measured values are stored. All val-
ues in a data line are stored on a separate line in the text file. An empty 
line is inserted after every data line. The data lines are stored from the 
bottom to the top. A small header at the beginning of the first data line 
contains the names of the channel and frame, as well as x-, y-, and z-
ranges with their physical units.

Comma separated z values (.csv) 

This format stores all the measured data in a chart, as a matrix of floating 
point numbers in ASCII format separated by a ‘comma’ and ‘SPACE’ char-
acter. This enables easy data exchange with commonly used spread sheet 
and database applications.



CREATING A REPORT
(X, Y, Z)-Points (.csv) 

This format stores the coordinates of all measured points in a chart as a list 
of floating point number pairs. For Line graphs, only X and Z points are 
exported.

 Print, Print preview...
Prints the currently selected measurement document together with the val-
ues shown in the Data Info panel.

Creating a report

The Nanosurf Report software package offers a powerful and extensive set 
of analysis functions. Complex analyses can be created interactively, and 
then displayed and printed in visually appealing reports. These reports can 
then be used as templates to apply the same analysis to another measure-
ment.

The Report software is started from the easyScan 2 software by either click-

ing , or using the Report menu. When a measurement is opened by the 
report software, it will import all measurement channels that are displayed 
in the current measurement document.
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Important!

• If you do not save the measurement in the easyScan 2 software, but only 
save the report, the data in measurement channels that were not displayed 
is lost.

• A measurement document should only display those channels that are 
used in a template. When a template is applied to a measurement docu-
ment that displays different, or a different number of measurement chan-
nels than the template uses, the results may not be correct.

The Report generator configuration dialog is used to configure the behav-
iour of the Navigator Icon and the Report menu. For an in depth introduc-
tion to the Nanosurf Report software, refer to the Introduction section of 
the Nanosurf Report on-line help.

The Report Menu

New Report
An empty report is opened.

Add Measurement
The currently active measurement is added to the currently opened report.

Apply Template...
Opens a dialog that allows you to select a template that is applied to the 
currently active measurement.

Template list
The template list is a list of the templates that are stored in the template 
directory (section The Report generator configuration dialog (p.68)). Select-
ing a template applies this template to the currently active measurement.

The Report generator configuration dialog
The Report generator configuration dialog is used to configure the behav-
iour of the Navigator Icon and the Report menu. It is opened using the 
menu ‘Options>Config Report...’.



CREATING A REPORT
Navigation bar

Determines what happens when the  icon is clicked. The check box 
determines whether the active measurement is evaluated using a template. 
The Browse-button is used to select the template that is used when the icon 
is clicked.

Report menu
Determines which templates are displayed in the lower part of the Report 
menu. The Browse-button allows the selection of the directory where the 
templates are stored.
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Automating measurement tasks

The Nanosurf easyScan 2 Scripting Interface is an optional component for 
automating measurement tasks. It offers several possibilities to automate 
measurement tasks:

• Create scripts inside the easyScan 2 software.

• Create external software that controls the easyScan 2 software.

This chapter describes the user interface features that are related to creating 
scripts inside the easyScan 2 software.

After purchasing it, the Scripting Interface must be activated using the Edit 
Access Codes dialog (section The Edit Access Codes Dialog (p.32), or follow 
the instructions on the Access code certificate delivered with the instru-
ment.)

For more information about the automating measurement tasks, and the 
available script commands, refer to the Programmers Manual. This manual 
is available as an on-line help file, that can be opened via the windows Start 
menu: ‘Start>Program files>Nanosurf>Nanosurf easyScan 2>easyScan 2
Programmers Manual’.

The Script Menu

The scripting functions of the easyScan 2 software are reached via the 
entries in the Script menu:

Script Editor...
Opens the Script Editor dialog.

Run From File...
On selecting this menu entry, a file dialog appears that allows selecting a 
script file by browsing. When the script is error free, the script will start 
executing on clicking the ‘Load’-button. Otherwise, and error message with 
an error description will appear.



THE SCRIPT EDITOR
Other entries
All scripts in the script directory are displayed below the Run From File 
menu entry. Selecting one of these entries starts the corresponding script. 
The example script ‘Show Remain Scantime’, which is installed in the 
default installation, should normally be listed here.

The Script Editor

The easyScan 2 software has an simple integrated Script Editor that allows 
editing, running, loading and saving scripts. The can be used in parallel 
with other application windows, so you can work with other parts of the 
application while editing a script. The Script Editor is accessed via the 
menu ‘Script>Script Editor...’.

Editor field
In the editor field in the center of the dialog you can edit scripts.

Run Button
Starts the currently loaded script. If there is an error in the script, a dialog 
box will appear.

The script editor
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The Script Configuration Dialog

The Script Configuration Dialog allows you to set the search path for the 
scripts that are displayed in the Script menu. The dialog is accessed via the 
menu entry ‘Options>Config script...’.



THE SCRIPT CONFIGURATION DIALOG
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